"Your license doesn't match the specified SKU"

How to resolve the "Your license doesn't match the specified SKU" error when licensing Patch My PC Cloud

SYMPTOMS

When I try entering my license key in the Patch My PC (PMPC) Cloud portal, I see the following:

Error

"Your license doesn't match the specified SKU (Enterprise Plus, Enterprise Premium). Please use the correct license key."

Error - Your license doesn't match the specified SKU (Enterprise Plus, Enterprise Premium). Please use the correct license key.

CAUSE

This message is caused if you are entering a Managed Services Provider (MSP) license key.

RESOLUTION

As detailed in Cloud Requirements, MSP license keys are not supported.

Note

If you have any feedback or comments on our docs, please email docs@patchmypc.com.

Last updated