Why do I see a yellow exclamation mark ("!") beside a Cloud deployment?

Applies to: Patch My PC Cloud

SYMPTOMS

I’ve successfully deployed an app using Patch My PC (PMPC) Cloud, but when I look at the deployment, I see a yellow exclamation mark ("!") beside it in the Status column.

Yellow exclamation mark beside a deployment

CAUSE

You need to hover over the exclamation mark ("!") as the message displayed will tell you what is causing the problem.

RESOLUTION

Follow the relevant section for the error message you are seeing.

Failed to add application with version ‘<version_number>’ to app limit reached’ ESP Profile.

“Failed to add application with version ‘<version_number>’ to app limit reached’ ESP Profile” error

This message is telling you that when the Sync Schedule ran, a new version of an app was detected, which we successfully deployed.

However, we could not add this new version to the Enrollment Status Page (ESP) Profile to which this app is deployed, as the profile has reached the limit of 100 apps.

Note

See ESP Profiles for more information.

To resolve this issue, you need to use the Intune admin center and from the ESP Profile remove either:

  • An app that no longer needs to be a member

  • The oldest version of the app.

Failed to apply new parent dependency for the child app '<app_name>' '<app_version>'

“Failed to apply new parent dependency for the child app '<app_name>' '<app_version>'” error

This message is telling you that the deployment of a dependency for this app has failed.

To resolve this issue, hover over the exclamation mark, which will tell you the name of the failed deployment.

Follow the Recreate a Deployment process to recreate this deployment, including all app dependencies.

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