“500 Internal Server Error” when adding an assignment to a Cloud deployment
Applies to: Patch My PC Cloud
SYMPTOMS
I am trying to create an assignment in the Patch My PC (PMPC) Cloud portal that previously worked.
Now, when I try to add an assignment, I get a 500 Internal Server Error.

CAUSE
The most probable cause of this is either someone has deleted the Patch My PC Cloud Enterprise App or a Global Admin has revoked the Permissions required for Intune Apps from within the Intune admin center.
RESOLUTION
To resolve this issue, follow the Reconnecting an Intune tenant process, which will prompt you to reconfirm you want to grant the Permissions required for Intune Apps.
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