“Group not found” shown for an Assignment of a successful Cloud deployment
Applies to: Intune Apps for Cloud
SYMPTOMS
I’ve successfully deployed an app using Intune Apps for Cloud (Intune Apps). However, when I look at its properties (by clicking on the deployment, pressing More Info, and expanding the Assignment Type), why does it show (Group not found) beside the assignment?

If I edit the deployment and click Assignments, I also see the Group not found. Please remove the assignment message.

CAUSE
This is because someone has deleted the group used for the assignment from Entra.
RESOLUTION
To resolve this issue:
Recreate and reconfigure the relevant group in Entra.
Edit the deployment in the portal.
Delete the relevant assignment.
Re-add the assignment by browsing to the recreated Entra group.
Complete the deployment.
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