"Error - Claim Ownership Failed"

How to resolve the "Error - Claim Ownership Failed" when trying to recover a Patch My PC Cloud Company

SYMPTOMS

I can no longer access my Patch My PC (PMPC) Cloud Company as the only admin has left and no other users have been created with the Full Admin with Access Management role.

I have tried running through the Recover Your Company process, but after entering the requested information, I see the following:

Error

Claim Ownership Failed

“Error - Claim Ownership Failed”

CAUSE

This error can occur for several reasons, such as:

  1. You have entered invalid data to attempt the recovery.

  2. You are trying to recover a PMPC Company from the wrong Entra ID tenant.

RESOLUTION

To resolve this issue:

  1. Verify you are entering the right values in the correct fields of the Claim Ownership wizard.

  2. Verify that the last five characters shown for the company you are trying to recover match the last five characters of the Entra ID tenant (the Directory (tenant) ID).

Important

You only have three attempts to complete the Claim Ownership wizard. After the third attempt, you will be locked out and prevented from attempting the recovery for 12 hours.

Note

If you have any feedback or comments on our docs, please email docs@patchmypc.com.

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