Why can’t I access my Company?
How to resolve an issue with not being able to access your Company in Patch My PC Cloud
SYMPTOMS
I am trying to onboard to the Patch My PC Cloud (PMPC) portal. My company is listed on the Select the Company You Want to Sign-In To screen and I’ve clicked Request Access.
However, no one remembers who registered the company, so I cannot gain access.
CAUSE
This problem occurs if someone has previously registered your company with PMPC Cloud.
RESOLUTION
At present, we are unable to disclose who registered a specific company.
So your options are:
Find out who registered your company and ask them to approve your access.
Create a new company with a different name.
Note
Once you obtain access to your company, ensure you set up more than one user with Access Management privileges as detailed in Managing Access Management privileges for a User. This will help you avoid this problem in the future.
Last updated