> For the complete documentation index, see [llms.txt](https://docs.patchmypc.com/llms.txt). Markdown versions of documentation pages are available by appending `.md` to page URLs; this page is available as [Markdown](https://docs.patchmypc.com/patch-my-pc-cloud/troubleshoot/discovery/why-is-the-edit-button-disabled-beside-a-cloud-managed-app.md).

# Why is the “Edit” button disabled beside a Cloud Managed App?

*Applies to: Patch My PC Cloud*

### SYMPTOMS

I have signed into the Patch My PC (PMPC) Cloud portal and navigated to the **Discovery** node, followed by the **Managed** tab.

I see the list of my managed apps, but why is the **Edit** button beside my app greyed out?

### CAUSE

This can occur for several reasons, including:

* The **Status** of the app is not showing as **Success** (it is in a **In Progress**, **Failed** or **Retrying** state).
* The signed in user does not have permission to edit deployments.
* Your PMPC Cloud portal license has expired.
* The deployment was made using our on-premises Publisher.

### RESOLUTION

To resolve this issue:

1. Check the **Status** of the relevant deployment. If it is showing as **Failed**, follow the [Troubleshooting an Intune Apps Deployment](/patch-my-pc-cloud/troubleshoot/deployments/troubleshooting-an-intune-apps-deployment.md) process.
2. Verify the user has not been assigned the **Custom App Admin** user role, as this role cannot edit deployments.
3. Follow the [Managing your License](broken://pages/8qjfvVWkH0JTJRXsuS6m) process to verify your license is still valid.


---

# Agent Instructions
This documentation is published with GitBook. GitBook is the documentation platform designed so that both humans and AI agents can read, navigate, and reason over technical content effectively. Learn more at gitbook.com.

## Querying This Documentation
If you need additional information that is not directly available in this page, you can query the documentation dynamically by asking a question.

Perform an HTTP GET request on the current page URL with the `ask` query parameter, and the optional `goal` query parameter:

```
GET https://docs.patchmypc.com/patch-my-pc-cloud/troubleshoot/discovery/why-is-the-edit-button-disabled-beside-a-cloud-managed-app.md?ask=<question>&goal=<endgoal>
```

`ask` is the immediate question: it should be specific, self-contained, and written in natural language.
`goal` is optional and describes the broader end goal you are ultimately trying to accomplish on behalf of the user. GitBook uses it to tailor the answer towards what is most useful for that goal.

The response will contain a direct answer to the question and relevant excerpts and sources from the documentation.

Use this mechanism when the answer is not explicitly present in the current page, you need clarification or additional context, or you want to retrieve related documentation sections.
